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Building Spreadsheets
The main reason for working in Excel is that it is able to perform calculations. Two methods are
employed to create calculations, formulas and functions. These terms are often used to mean the
same thing although strictly speaking they are different, and sometimes they are combined into
one calculation.
When performing a calculation in Excel you enter the formula or function into a cell. When you
leave the cell it displays the result of the calculation. When you select a cell that contains a
calculation the expression "behind" the displayed value is shown in the formula bar (Fig.1).

Fig.1 The selected cell's formula is shown in the formula bar.

Calculating with Formulas
A formulai is an expression designed to perform a calculation using mathematical operatorsii (e.g.
plus, minus, divide, multiply etc.) and values. The values may be entered directly into the
expression (e.g. =B2*17.5%) or by referring to a cell containing the value (e.g. =B2*G1%
where cell G1 contains the number 17.5). A complete list of operators is shown in the table below.
Operator

Keyboard Character

Meaning

+

Plus sign

Add

-

Minus sign

Subtract

/

Forward slash

Divide

*

Asterisk

Multiply

%

Percent sign

Percent

^

Caret

Exponential

>

Right angled bracket

Greater than

<

Left angled bracket

Less than

=

Equals sign

Equal to

&

Ampersand

Concatenates text

A formula must always start with an equals sign (=). When you finish entering a formula press
[Enter] to accept it. The result of the formula will now show in the cell.
Formulas calculate from left to right with multiplication and division being calculated before
addition and subtraction. You should always check that you have written your formulas correctly to
achieve the result you require. The priority order can be changed with the help of parentheses
(round brackets ()).
In the example illustrated above (Fig.1) the calculation must show the total cost of an order of 25
items, each costing £4.95 plus £0.87 tax. If the formula had been written =B2+C2*D2 Excel
would have multiplied the values in cells C2 and D2 first, then added the value in cell B2. This
would have given the wrong result because it would have multiplied quantity by tax then added the
price. To get Excel to calculate in the order required parentheses are used to enclose those parts of
the expression that must be performed first. The correct way to write the formula is
=(B2+C2)*D2 which forces Excel to first add together the values in cells B2 and C2 then multiply
the result by the value in cell D2. This adds the tax to the price then multiplies the result by the
quantity.

Calculating with Functions
A functioniii is a predefined formula that performs a calculation by using specific values in a
particular order. Each function has a name (e.g. SUM, AVERAGE, STDEV etc.) conventionally
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written in capitals. The values, which can be typed directly into the function or supplied as
references to cells containing the values, are known as argumentsiv.
Functions always start with an equals sign. This is followed by the name of the function then the
required arguments in brackets, the arguments separated by commas. For example, the function…
=SUM(A2, B2, C4:D5) adds the values in the cells A2, B2 and the block C4 to D5 (Fig.13).
Excel contains a large library of functions and offers help on how to use them. If you know the
syntax of a function you can type it directly into a cell. As you start to type Excel displays a list of
available functions whose names start with the letters you have typed. Clicking on a name in the
list displays a brief description of what the function does. You can continue to type or double-click
the name of the one you want to use to insert it into the cell. A soon as Excel recognises the name
of the function you are entering it displays help in the form of a tooltip showing the required
arguments.
In the illustration (Fig.2) the SUM function is being used to add the values in a column of cells.
After typing the function name ("SUM") an opening bracket is typed before entering the
arguments. This prompts Excel to display a tooltip indicating which arguments are required, in this
case number1, [number2] etc. (the SUM function accepts up to 30 arguments). The argument
shown in bold type in the tooltip is the one that Excel expects you to supply now. Type a comma
before adding another argument but do not finish with a comma, and remember to type a closing
bracket at the end. Arguments shown on the tooltip in square brackets are optional and may or
may not be required depending on how you are using the function.

Fig.2 Entering a function into a cell.

When entering arguments as cell references you can either type the cell address or select the cell,
or block of cells, with the mouse. As you do this Excel automatically enters the cell reference into
the function. It also colours the cell reference and draws a coloured rectangle around the cells that
the reference applies to. When you finish typing the function press [Enter] to accept it. The result
of the function will now show in the cell.
If you require more help when entering a function you can use the Insert Function tool. First select
the cell into which you want to place the function. Click the Insert Function button at the leftmost
end of the Formulas tab of the Ribbon (Fig.3) or click the Insert Function button (marked fx)
just to the left of the formula bar.

Fig.3 The Formulas tab of the Ribbon.

This opens the Insert Function dialog box (Fig.4) where you can choose a function from a
categorised list.

©Martin Green www.fontstuff.com

2

Microsoft Excel 2007/2010

Building Spreadsheets

Fig.4 Choosing a function from the
Insert Function dialog box.

Fig.5 The Insert Function dialog prompts for
the required arguments.

Clicking on a function name displays a brief description to help you choose. There is also a link to
Help on the selected function.
To supply the required arguments first click in the appropriate argument textbox in the dialog. The
dialog displays a description indicating exactly what is required. Then either type into the textbox
or select the cell (or range of cells) that contain the required information. As you proceed you can
see the function being built in the formula bar. Supply each required argument then click the OK
button to complete the process.
The example shown here (Fig.6) uses the PMT function, used to calculate the repayments on a
loan. There are three required arguments and two optional ones. Cell B1 contains the interest rate
as a percentage for the Rate argument and, since the payments will be monthly, the value is
divided by 12 (the /12 is typed directly into the argument textbox). Cell B2 contains the term of
the loan (i.e. the number of payment periods, expressed here in months) which supplies the value
for the Nper argument. Finally, cell B3 contains the present value of the loan (i.e. the amount
borrowed) which is entered into the Pv argument textbox as a negative value since the balance is
in debit.

Fig.6 Writing a PMT function using the Insert Function tool.

As you enter the arguments the Insert Function dialog displays their current values as well as the
final result of the calculation. When you complete the function and close the dialog the function
result is shown in the cell.
You can revisit the Insert Function dialog at any time by first clicking on a cell that contains a
function then opening the Insert Function tool in the usual way. The dialog will open with the
arguments already filled-in.
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Referring to Cells on a Different Worksheet
Since every worksheet has the same collection of rows and columns, all with the same names,
when you want to refer to a cell that is on a different worksheet you must also include the name of
the sheet in the cell reference. Cells on the current worksheet (the same sheet as the cell that
contains the formula or function) are always referred to by their simple address (e.g. A1).
If the cell is on a different worksheet in the same workbook you must add the worksheet name
followed by an exclamation mark (!) in front of the cell address (e.g. Sheet2!A1). If that
worksheet name contains spaces the name must be enclosed in single quote marks (') (e.g.
'Balance Sheet'!A1). If the cell is located on worksheet in a different workbook then both the
workbook and worksheet names must be included in the reference. The workbook name must be
enclosed in square brackets ([]) and the workbook/worksheet combination enclosed in single
quotes if either contains spaces (e.g. '[Trading Statement 2007.xls]Sheet2'!$A$1).
If you can't remember the correct syntax you can get Excel to write it for you by starting to write
your formula or function in the normal way then, when you need to enter the remote referencev,
switch to the appropriate workbook and/or worksheet and click on the cell you need in your
calculation.

The AutoSum Tool
The AutoSum tool provides a quick and easy way to insert simple, commonly used functions into
your spreadsheet. To add a total to a column of cells select an empty cell at the bottom of the
column then click the AutoSum button located on both the Home and Formulas tabs of the
Ribbon. Excel writes the SUM function into the cell to include the entire column of cells above the
selected cell (this also works if you select an empty cell at the right of a row of cells). The cells to
be included in the SUM function are enclosed by a dotted line and the function itself is displayed in
the selected cell (Fig.7). If there are gaps in your column of cells Excel might not select the entire
column. If this happens simply select the cells to be summed manually whilst the dotted line is
visible. When you are happy with the result press [Enter] to complete the process.

Fig.7 Using the AutoSum tool.

The AutoSum tool is very flexible. If you select a column of cells then click the AutoSum button
Excel will place a total at the bottom of the column. Select a row and AutoSum will place a total to
the right of it. If your selection contains several columns AutoSum will place a total at the bottom
of each column. To force it to place a total to the right of each row, include an empty column in the
selection to the right of the data. Maybe you want a gap between the totals and the data cells –
first select the cells in which you want the totals to appear then click the AutoSum button. Excel
can usually comply with your wishes.
The AutoSum tool is not limited to the SUM function. You can also use it to quickly enter the
AVERAGE, COUNT, MAX and MIN functions. Select cells as described above then click the downarrow next to the AutoSum button and choose a function from the list (this feature is not available
in versions of Excel prior to Excel 2003).
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Absolute and Relative Cell References
When building a spreadsheet you can save time retyping calculations by copying and pasting an
existing calculation into other cells. This can be done using the usual Copy and Paste commands
or with the help of the Fill Handle (the Fill Handle is the black dot in the lower-right corner of a
selection which can be dragged to copy the selection into adjacent cells).
When you do this the cell references used in the formula or function change relative to the location
of the cell into which they have been copied. So, if a calculation that contains a reference to cell A1
is moved down a row the reference automatically changes to A2 and so on.
In the example illustrated below (Fig.8) the formula =(B2+C2)*D2 has been entered into a cell
and the fill handle has been used to copy it down the column. Excel has automatically changed
each cell reference in the formula so that it refers to the correct cells, relative to its new position
on the sheet.

Fig.8 When formulas or functions are copied to a new position their cell references change.

This behaviour is often what is required but sometimes that is not the case. Supposing one of the
values in a calculation is to be found in a single cell, and it is always in that cell regardless of where
the calculation is made. For example, the rate of tax can be included in each calculation (e.g.
=B2*17.5%). But if the tax rate changes all the cells containing this value have to be edited.
Instead, the tax rate could be stored in a different cell to which all the various calculations could
refer (e.g. =B2*G1, =B3*G1 etc.). This seems like a good idea but it has an implication on how
you write the formula if you plan to copy it into other cells. Simply copying the formula down the
column causes all its references to change, so although the first formula looks in the correct cell
(G1) for the tax rate, the cells below it look in cells which correspond to their position (G2, G3, G4
etc.) and since these cells are empty (or might contain values other than that required) the
formulas don't work as they should, in this example returning a value of zero (Fig.9).

Fig.9 Using a relative reference here caused incorrect results.

In this example the reference to the cell was a relative referencevi, meaning it would change
relative to its new position if the calculation in which it was used was moved or copied to
somewhere else.
The solution is to use an absolute referencevii. This is a reference in which all or part of the cell
address is "frozen" so that it never changes when the calculation using it is copied or moved to
another place. You can recognise relative references by the presence of a dollar sign ($) before the
part of the reference that is to be frozen. In this example the cell containing the tax rate (G1)
would be written as an absolute reference ($G$1). When the formula is copied down the column
the relative reference, which refers to the cell containing the Price changes as it should, but the
absolute reference, referring to the cell containing the tax rate, remains the same (Fig.10).
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Fig.10 Using an absolute reference prevents the cell address changing.

Here both the column and row parts of the cells address have been frozen by placing a dollar sign
in from of them ($G$1). In some circumstances you might want to freeze just the column part of a
reference (e.g. $G1) or just the row part (e.g. G$1).
When creating absolute references you can either type the dollar signs directly into the formula or,
more conveniently, press the [F4] key immediately after typing the cell reference. This method
also works if you enter a cell or range reference by selecting cells with the mouse. If you want to
convert a relative reference into an absolute reference after it has been created, simply place your
cursor in the reference in the formula bar and press the [F4] key.

Viewing and Editing a Calculation
You may need to make changes to a function, or it may be difficult to understand how a calculation
in a cell relates to the spreadsheet on which is resides. Excel provides some helpful ways to see
where a calculation is getting its values from so that you can accurately make any desired changes.
As mentioned above, you can select a cell containing a function and then open the Insert Function
tool to see how is was built. This allows the function to be edited by changing values or cell
references in the argument textboxes.
Excel can also display a colour-coded version of your formula or function in which the cell
references are each shown in a different colour with matching coloured borders shown around the
relevant cells. Activate this by selecting a cell containing a calculation then clicking in the formula
bar (Fig.11). Alternatively, double-click on a cell that contains a calculation (or click again on an
already-selected cell) to reveal the entire colour-coded formula and a function tooltip (if
appropriate)(Fig.12 and Fig.13).

Fig.11 The function in the formula bar shows
colour-coded cell references.

Fig.12 The function in the cell displays
colour-coded cell references

If you need to change the ranges referred to in a calculation displayed this way you can do it by
resizing the range boxes by dragging the coloured dots at their corners, or by moving them by
dragging the coloured lines that form their edges.
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Fig.13 Colour-coded ranges make editing calculations easy.

To see all the calculations on a worksheet displayed at one time, instead of their resulting values,
click the Show Formulas button on the Formulas tab of the Ribbon or use the keyboard shortcut
[Control]+[`] (the [`] key is usually located to the left of the [1] key on the keyboard). This
command toggles between showing and hiding all the calculations on a worksheet (Fig.14).

Fig.14 A Worksheet's formulas and functions revealed using [Control]+[`].

Another way to examine calculations is with the help of the Formula Auditing tools which are
located on the Formulas tab of the Ribbon (Fig.15). These tools provide a wide variety of useful
ways of auditing a worksheet. For viewing the elements of a calculation the Trace Precedents and
Trace Dependents tools are used.

Fig.15 The Formula Auditing section of the Ribbon.

At its simplest, the Trace Precedents tool indicates which cells contain the values that are referred
to in a formula or function. Use this when you want to ask the question "Show me the cells that are
used in this calculation". Select the cell containing the calculation and click the Trace Precedents
button. Excel draws arrows to the selected cell from the cells that directly supply it with a value
(Fig.16 and Fig.17). Remove the arrows by clicking the Remove Precedent Arrows button.

Fig.16 Tracing the precedents of a PMT function.

Fig.17 Tracing the precedents of a SUM function.

If the first set of precedent cells themselves contain calculations they will have their own
precedents. You can reveal these by clicking the Trace Precedents button again, and continue
doing so until all the cells on which the selected cells depends have been traced (Fig.18).
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Fig.18 Precedents can be traced back many steps.

If a precedent is located on another worksheet, or in a different workbook, this cannot be traced
directly so Excel displays an arrow to its dependent cell from a worksheet icon (Fig.19).

Fig.19 The value in B1 comes from a different worksheet.

If you want to ask the question "show me the cells containing calculations that use this cell's value"
then select the cell and use the Trace Dependents button. This works in exactly the same way as
Trace Precedents but in the opposite direction.

Formatting a Worksheet
Formatting is an important task when designing a spreadsheet. The purpose of formatting is not
just to make a spreadsheet look pretty. Good formatting not only makes the spreadsheet look good
but can make it easier to read and understand. A selection of the most commonly used formatting
commands are included on the Home tab of the Ribbon (Fig.20).

Fig.20 The Home tab of the Ribbon.

Many of the formatting options are the same familiar ones you would find in many other programs,
such as Microsoft Word. You can specify the font, point size and style (e.g. bold, italic, underlined),
alignment and colour of the data displayed in the cells just as you would in your word processor.
More specific to Excel are commands relating to how numbers and dates are to be displayed, how
many decimal places to show, whether or not to show values as currency or percent. And since a
worksheet is essentially a grid, you can choose to add different kinds of borders to cells and specify
the border colour. You can also choose a fill colour for the background of the cells.
The full range of formatting commands can be found by opening the Format Cells dialog box
(Fig.22). Do this by clicking one of the small arrow buttons located in the lower-right corner of the
appropriate section of the ribbon (Fig.21). In the Format Cells dialog the various formatting
commands are grouped into categories. To use any of the formatting commands first select the cell
or cells you want the format to apply to then give the command using a button on the Ribbon or by
going to the format cells dialog.
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Fig.21 Open a dialog box by clicking the arrow
button on the Ribbon.

Fig.22 The Format Cells dialog box.

If you need inspiration when formatting your spreadsheet consider using one of the many readymade Cell Styles and Table Formats. To format individual cells or blocks of cells the same way
select the cells and click the Cell Styles button in the Styles section of the Home tab of the
Ribbon. This displays a palette of ready-made cell formats (you can also create your own) which
are previewed on the cells you have selected as you move the mouse over each style on the
palette.
More complex formats can be obtained by choosing from the many available Table Formats. These
formats offer a range of different styles at one go, including row or column banding and different
styles for heading and total rows and columns. First select the cells you want to format then click
the Format as Table button in the Styles section of the Home tab of the Ribbon. Choose one of
the styles from the palette then confirm your selection when the Format As Table dialog box
appears.

Fig.23 The Format As Table tool will intelligently format your spreadsheet.

When your newly formatted table is selected a new Design tab appears on the Ribbon offering a
range of additional options. When formatting your data this way Excel also converts the selected
range into an Excel Table which has additional implications which are designed to help you work
with the data including automatic formatting of new data and automatic insertion of formulas. It
also places filter buttons at the head of each table column. If you don't want to take advantage of
these features you can simply convert your table back to a regular range without losing the
formatting you have just applied. To do this select any cell in the table to activate the Table
Design tab of the Ribbon and click the Convert to Range button.

Formula – An expression made up of mathematical operators and values that performs a calculation. In Excel a formula always
starts with the equals sign = and can combine the operators + - / * % ^ & < > & as well as parentheses ().
i

ii

Operator – A symbol (e.g. + - / * = ^ %) that specifies the type of calculation to perform on the elements of a formula.
Function – A predefined named formula that performs a calculation using specific values (arguments) in a particular order.

iii

Argument – A specific value used to perform a calculation in a function. It can be supplied as a literal value or a reference to a
cell (or range of cells) containing the value(s).
iv

v

Remote Reference – A reference in a formula or function to a cell or range on a different worksheet.

Relative Reference – A cell reference which can be changed automatically by Excel when the formula or function using it is
copied or moved to a different position on the worksheet (e.g. A1)
vi

vii

Absolute Reference – A cell reference which is wholly or partly frozen so that it does not change when the formula or function
using it is copied or moved to a different position on the worksheet (e.g. $A$1, $A1, A$1 etc.).
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