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Building Charts
There are many ways to display data on an Excel worksheet but perhaps the most valuable tool
when presenting your data is the chart. We use the term chart to refer to any one of the many
ways of displaying data in a graphical format. The older term graph is now usually restricted to line
charts.

Prepare the Data
Data that is to be charted should be arranged logically on the worksheet in a block of rows and
columns, both of which should have headings. Try to avoid including completely empty rows or
columns. The example illustrated (Fig.1) shows the projected annual sales for a company for
various different regions (Europe, North America etc.) for a 10 year period (shown as Year 1, Year
2 etc.). It does not matter if the data is arranged in rows or columns because you can make
decisions about how it will appear when you are building the chart.

Fig.1 A sample of data to be charted.

Select the Data to be Charted
Select the block of data that you want to appear in the chart, remembering to include the row and
column headings (Fig.2). Excel will allow you to change the range of data shown when you have
finished building the chart.

Fig.2 Select the data to be charted.

If you do not want to chart the entire range of data then select only that which you want to see
charted. If you want to chart various sections of the data that do not form a continuous block you
can make a non-contiguous selection by selecting one block with the mouse, then holding down the
[Control] key whilst selecting another block, remembering always to include the cells containing
the headings (Fig.3 and Fig.4).
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Fig.4 Selecting non-contiguous rows.

Fig.3 Selecting non-contiguous columns.

When making a multiple selection, select the data in a logical order starting with the row or column
headings. This helps Excel decide how the data should be arranged on the chart. When you create
the chart, if the data is not arranged as you intended, you will be able to make changes to specify
exactly how it should appear.

Create the Basic Chart
Earlier versions of Excel included a Chart Wizard tool to guide you through the steps of creating a
chart. Excel 2007 does not use this wizard and instead provides all the tools you need on the
Ribbon. Having selected the data to be charted go to the Insert tab of the Ribbon where you will
find a section devoted to charts (Fig.5).

Fig.5 The Charts section of the Ribbon.

You can either choose one of the basic chart types illustrated on the Ribbon or click the small arrow
below one of the icons to display a palette of variations on that type of chart (Fig.6). Alternatively
click the small arrow button in the lower-right corner of the Charts section of the ribbon to display
the Insert Chart dialog box in which all the available chart types are displayed in one place
(Fig.7).

Fig.7 The Insert Chart dialog shows all available chart types.

Fig.6 The available variants of a
chosen chart type.

When you make your choice a chart appears on the worksheet. The chart is created as a floating
object (a Shape) on the worksheet and can be moved and resized in the usual way.
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Fig.8 The basic chart created by the Chart Wizard.

Notice that when the chart object is selected (so that you can see its transparent border and dotted
resizing handles around its edge) the data represented in the chart is outlined on the worksheet
with coloured rectangles in the same way that the component ranges of a formula are displayed in
different colours (Fig.8). You can resize these coloured rectangles to change the range of data
displayed by the chart.
Note also that when the chart is selected Excel displays three new tabs on the Ribbon, grouped
under the heading Chart Tools. These are:


Design – providing Type, Data, Chart Layouts, Chart Styles and Location tools.



Layout – providing Current Selection, Insert, labels, Axes, Background, Analysis and
Properties tools.



Format – providing Current Selection, Shape Styles, Word Art Styles, Arrange and Size
tools.

Choosing the Right Type of Chart
It is important to choose the right type of chart to best display your data. What might look
attractive may not necessarily show your data in a format that is easy to read and understand. In
the example above (Fig.8) a Clustered Column chart was chosen which does not display the data in
a way that is easy to compare the different regions. A simple Line chart makes it much easier to
see and compare the trends in the data (Fig.9).

Fig.9 The same data displayed as a Line Chart.
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It is easy to change the chart type. Simply click on the chart to select it and on the Design tab of
the Ribbon click the Change Chart Type button to display the Change Chart Type dialog box
(similar in appearance to the Insert Chart dialog (Fig.7)) then make a choice and click OK.

How the Series are Arranged
Excel guesses how to display your data according to how you have arranged it on the worksheet
and, when you make a multiple selection, the order in which the different sections of data were
selected. In this example a multiple selection was made to include the headings and the data for
Year 1, Year 5 and Year 10 for all the regions. Excel has guessed what I require and has plotted
Region (on the x-axis) against the numerical data (on the y-axis) with each year as a separate
series (Fig.10 left) but I wanted to see Year on the x-axis with each region as a separate series
(Fig.10 right).

Fig.10 Choosing how the series are arranged.

Changing the arrangement of data on your chart is a simple matter. Select the chart and on the
Design tab of the Ribbon click the Switch Row/Column button. If this does not achieve the
arrangement you require try the Select Data button, also on the Design tab which gives even
greater control. The Select Data Source tool also allows you to add, edit or remove Legend
Entries and their associated series, and Horizontal Axis Labels and their associated categories. This
makes it easy to specify which data to plot in a way that might be easier than creating a multiple
selection. The illustration below (Fig.11) shows the result of removing two of the regions from the
original multiple selection using this method.

Fig.11 Defining the plotted data using the Select data Source dialog.
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Moving and Resizing the Chart
The size and shape of the chart that Excel creates for you might not be just right for the purpose
you have in mind. Will it be viewed on screen, printed out either on its own or together with its
spreadsheet data, or maybe you plan to paste it into a report in Microsoft Word or include it in a
Microsoft PowerPoint slideshow. Since the chart is created as an object floating on the worksheet it
can be moved and resized in the same way as you would change a drawing or picture.
The mouse pointer shows when you can move or resize an object (Fig. 12). To move the chart
select it and point at an empty section of the Chart Area so that the mouse pointer displays a fourheaded arrow then drag the chart to the desired location on the worksheet. To change the size of
the chart by pointing at the dotted resizing handles located at the corners and along the sides of
the chart border until the mouse pointer displays a diagonal or horizontal double-headed arrow
then drag the border to alter the size.

Fig. 12 The mouse pointer indicates that the chart can be moved or resized.

If you want to be precise the Format tab of the Ribbon includes a Size section where you can
specify the exact dimensions of the chart object.

Changing the Chart Location
As described so far, the chart is an object on the same worksheet as the data it displays (like this it
is called an embedded chart). This is useful because it allows you to see the data and the chart at
the same time and it allows you to easily modify the size of the range charted. But it isn't always
desirable to do this so, if you prefer, Excel can display the chart on a sheet of its own (called a
chart sheet).
Right-click anywhere on the chart and choose Move Chart. In the Move Chart dialog box select
New sheet and enter a suitable name in the textbox (Fig.13). When you click the OK button the
chart is moved to a new sheet of its own.

Fig.13 Placing a chart on its own sheet.

If at any time you want to return the chart to its original worksheet, or place it on a different
worksheet (a chart does not have to be embedded on the same sheet as its data), right-click on
the chart and enter your choices into the dialog box.

Formatting the Chart
A chart is made up of many different elements, each of which can be formatted in a wide variety of
ways so that you can make your chart look almost any way you wish.
For major changes of colour scheme check the Chart Styles section of the Ribbon's Design tab
(Fig.14) from where you can apply one of many different schemes designed for your particular kind
of chart. First click on the chart to select it then click on your chosen scheme to apply it to the
chart. Choose an option from the Chart Layouts section to specify whether or not you want your
chart to include a Legend, Title or Data Table and where you want them located.
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Fig.14 The Chart Design tab.

For more control, go to the Layout tab (Fig.15) of the Ribbon where you can fine-tune each of
these options.

Fig.15 The Chart Layout tab.

For complete control select the specific part of the chart you want to change and apply your chosen
format. Excel makes it easy to do this. When you hover the mouse pointer over a specific part of
the chart a tooltip appears next to it giving the name of the part. To select it just click the mouse
and apply your chosen format from the appropriate tab on the Ribbon. Alternatively, right click the
chart item and choose Format [name of item] (e.g. Format Gridlines) from the menu to open a
dialog box with all the available formatting options listed.
In the upper left corner of the Layout and Format (Fig.16) tabs is a section labelled Current
Selection. It contains a drop-down list of all the chart elements. You can choose an item from this
list to select it on the chart then click the Format Selection button just below it to open the
Format dialog box.

Fig.16 The Chart Format tab.

Making the Most of Your Chart
In business many would agree that the presentation of data is just as important as the data itself.
With Excel's powerful charting tool the possibilities are endless. A chart that looks good and is clear
and easy to understand is a great asset. A chart's design should be simple and clear. Don't include
things that aren't necessary but make sure that everything is present that is needed to understand
what is being displayed. Here are some suggestions…
Whilst Excel’s chart tools can very easily create a good-looking chart, don’t always be satisfied with
what the program gives you. This example (Fig.17) illustrates how making a few small changes can
substantially improve the appearance of a basic chart. The most obvious change results from
moving the Legend which in the default position to the right of the plot area takes up a great deal
of space, partly due to the long series names. It has been moved to an empty area in the upper
left section of the plot area and also condensed by placing the individual legend items closer
together (simply by changing the size of the legend box). This allows the important part of the
chart, the plot area itself, to occupy a much larger space.
The horizontal gridlines made the plot area cluttered so they have been deleted and the axis line
colour changed from grey to black to make them more prominent. In addition the vertical axis
number format has been changed to Currency. Finally, a Chart Title has been added. Never assume
that the person viewing your chart knows what it represents. Every chart should have a title that
clearly states what is being shown.
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Fig.17 Making a few simple improvements to the basic chart.

The chart shown in the illustration below (Fig.18) is plotting a single series of data so is ideally
suited to a column chart. The legend is unnecessary and has been deleted. A more stylish 3-D fill
has been chosen for the vertical bars and the gap between them has been reduced to 10%. Data
labels have been added in a contrasting colour to show the exact value of each data point. The
columns are the same colour because they all belong to the same series and there was no need to
make them different. This would only have confused the view, although you might want to change
the colour of a single data point if it had a special significance.

Fig.18 A single series column chart.

Single series charts can also be suitable for displaying as a pie chart. Pie charts are often used
when it is required to show each data point as a percentage of the total (Fig.19). Each "slice" of the
pie represents a single data point and the slices are usually coloured differently. Whilst you can
display a legend with a pie chart individual data labels are a better choice and Excel offers a range
of options. If the pie slices are too small to accommodate the label text the labels can be placed
around the perimeter of the pie with optional leader lines to clearly indicate which slice each label
refers to.
In the next example (Fig.19) the legend has been replaced by data labels showing the Category
Name and Percentage value of each slice; the Chart Title has been edited to be more meaningful
and the 3-D Rotation of the chart has been adjusted to bring the smaller slices to the front. For
emphasis one slice has also been dragged a little way out of the pie.

Fig.19 A single series pie chart.
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